Меню

Rb1100ahx2 настройка сети и выход в интернет на отдельном интерфейсе

Rb1100ahx2 настройка сети и выход в интернет на отдельном интерфейсе

Настройка оборудования MikroTik

Резервирование, агрегация, VPN, скрипты для решения нестандартных задач.

2 wan интерфейса static ip на RB1100AHx2

Роутер настроен и работает, статический ip
Сейчас возникла задача подключить еще один wan интерфейс другого провайдера, статический ip для того что-бы выпустить в инет локальную подсеть с другой адресацией через нового провайдера и они всегда будут ходить только через него.
Старая подсеть будут ходить как и раньше через старого провайдера
Понимаю что связано с маркировкой пакетов и маршрутами
Подкиньте примеров рабочих или ткните куда копать примерно
Вроде примеры находил, настроил, не работает

Сделал не работает

Вы ссылку выше читали.
Там все намного проще.
Для чего перемаркировки.
Для чего роут таблицы.

Точнее даже не так: сначала настраиваете все по мануалам. Самый простой вариант. Убеждаетесь, что он работает, и только потом начинаете накручивать плюшки.

Аналогичная схема дома у меня

вот приемр конфига

Создаем адрес листы 192.168.2.0/24 и 192.168.1.0/24 смотрят в PPPoE, 192.168.3.0/24 в IPoE

/ip firewall address-list
add address=192.168.1.0/24 list=home
add address=192.168.2.0/24 list=home
add address=192.168.3.0/24 list=corporate

Маркируем роутинг, чтобы дефолт для 192.168.3.0/24 смотрел в другой интерфейс
/ip firewall mangle
add action=mark-routing chain=prerouting new-routing-mark=inside passthrough=\
no src-address-list=corporate

Применяем маркировщик
/ip route
add distance=1 gateway=192.168.250.1 routing-mark=inside

Добавляем правило нат
/ip firewall nat
add action=masquerade chain=srcnat out-interface=pppoe-out1 src-address-list=\
home //это первый провайдер работает через PPPoE
add action=masquerade chain=srcnat out-interface=ether6 src-address-list=\
corporate

Т.о. имеем два маршрута по умолчанию, но для 192.168.3.0/24 шлюзом будет 192.168.250.1

у меня заработало вот так

ip wan статика
как видите у WAN_2 и WAN_3 одинаковые ip шлюза
ни первый шлюз ни первую локальную сеть LAN_1 не трогал вообще, там настроек сколько что не хочется копаться, тем более это не стенд, там 120 компов в локалке, vpn, сервер pppoe и куча wi-fi точек
завернул только LAN_2 в WAN_2
и LAN_3 в WAN_3 без балансировок и резервирования, уже полдня полет нормальный
может и не по mikrotik феншую, но работает

WAN_1 80.80.80.80/30 GATEWAY 80.80.80.81
WAN_2 70.70.70.70/19 GATEWAY 70.70.64.1
WAN_3 70.70.70.71/19 GATEWAY 70.70.64.1
LAN_1 192.168.1.0/24
LAN_2 172.16.0.0/24
LAN_3 172.16.1.0/24

/ip firewall mangle
add action=mark-routing chain=prerouting new-routing-mark=TELECOM_1 src-address-list=TELECOM_1
add action=mark-routing chain=prerouting new-routing-mark=TELECOM_2 src-address-list=TELECOM_2

/ip firewall nat
add action=src-nat chain=srcnat comment=»TELECOM_1″ out-interface=ether3 to-addresses=70.70.70.70
add action=src-nat chain=srcnat comment=»TELECOM_2 out-interface=ether4 to-addresses=70.70.70.71

/ip route
add check-gateway=ping distance=1 gateway=70.70.64.1%ether3 pref-src=70.70.70.70 routing-mark=TELECOM_1
add check-gateway=ping distance=1 gateway=70.70.64.1%ether4 pref-src=70.70.70.71 routing-mark=TELECOM_2

Источник

Настройка роутеров MikroTik: интернет, Wi-Fi, локальная сеть

Наверно это одна из самых лучших фирм, которая выпускает не просто качественное оборудование, но при этом по приемлемой цене. Хочется отметить, что при низкой цене вы получаете друга, который будет с вами долгое время. Но есть небольшое «но» – функционал у каждой такой коробочки настолько широк, что зачастую даже опытные пользователи стопорятся в его запуске.

Но это с другой стороны и плюс. Вот у меня есть домашний роутера от ZyXEL, да он не плох, но функции у него настолько урезаны, что зачастую, если хочешь что-то сделать – то просто не можешь, так как нем не заложены такие функции.

Толи дело MikroTik, у него присутствует огромный ряд функций, что способно превратить его в настоящий мини-сервер. Операционная система у всех моделей почти одинаковая, так что эта инструкция поможет каждому обладателю этих чудных коробочек.

Настройка MikroTik не так сложна, как кажется на первый взгляд, просто надо выполнить достаточно много шагов, которые могут запутать первопроходца. Сегодня мы разберём пошаговую инструкцию для чайников как настроить аппарат от фирмы MikroTik.

Внешний вид и особенности

Давайте рассмотрим его поподробнее, перед тем как разберём вопрос.

У нас есть вход для питания, кнопка сброса настроек. Два индикатора. И дальше специальный порт PoE, который предназначен для питания по витой паре. Для этого в коробке есть отдельный разветвленный с двумя концами: кабель на выход RJ45 и питания.

Подключение

Устанавливаем аппарат, подключаем питание. Провод от провайдера и кабель, который будет идти к ноутбуку или компьютеру можно втыкать в любой из портов с надписью Ethernet.

Читайте также:  Настройка нажатия пера в фотошопе

Как зайти в MikroTik? Настройка происходит как с Web-интерфейса, так с помощью специализированной программы WinBox. Я считаю, что с проги управление и настройка, куда удобнее, чем с Веб-страницы.

Теперь просто ждём пока роутер сбросит конфиг до заводских. Иногда бывает, что этого не происходит, тогда в консоли надо вписать поочередно две команды:

После этого он перегрузится с нулевой конфигурацией.

ПРИМЕЧАНИЕ! Все ниже перечисленные инструкции по настройке роутера Микротик подходит для всех моделей: RB951G-2HND, RB750R2, HEX LITE, RBMRTG, RB4011IGS+RM HEX S, RB2011UIAS-RM, RB3011UIAS-RM, RB2011UIAS-IN, RB2011ILS-IN, RB2011IL-RM, RB2011IL-IN, RB1100AHX4 DUDE EDITION, RB1100AHX2, CCR1016-12G, CCR1016-12S-1S+, CCR1036-12G-4S, CCR1036-8G-2S+, CCR1036-12G-4S-EM, CCR1036-8G-2S+EM, CCR1072-1G-8S+, CCR1009-7G-1C-1S+PC, CCR1009-7G-1C-1S+, CCR1009-7G-1C-PC, RBMRTGX2, RB1100AHX4, RBMRTGX4, UBIQUITI EDGEROUTER INFINITY, UBIQUITI UNIFI SECURITY GATEWAY PRO, UBIQUITI EDGEROUTER.

Обновление ОС

Я бы рекомендовал сразу же установить актуальную прошивку.

Настройка портов

При сбросе настроек, все порты становятся равнозначные и их надо настроить. На стандартных маршрутизаторах, от других компаний идёт один порт для интернета и остальные для локального подключения устройств (заводские настройки). 1 WAN и 4 или более LAN портов. Здесь вы можете настроить на любой порт WAN и LAN – режим. Также можно использовать хоть сколько WAN – портов.

И так наша задача настроить несколько ЛАН портов, 1 WAN (или интернет порт). Также не забудьте, что если вы один порт используете в качестве подпитки PoE (Обычно это первый), то его мы не будем настраивать.

Настройка IP интерфейса

Если у вас офис или небольшая организация, то стоит задать IP роутера под маску сети, которую вы используете. Особенно это полезно, когда на рабочих компах уже проставлены статические IP адреса.

Интернет

Настроек очень много, но я постараюсь рассказать про самые популярные.

Если есть привязка MAC адреса

Теперь вписываем команду:

/interface ethernet set eth5-wan mac-address=MAC-адрес зарезервированный провайдером.

Также замените значение eth5-wan на номер порта, который используется у вас для интернета. Я использую пятый порт, но вы можете использовать и eth2-wan, eth3-wan или eth4-wan

Динамический IP

Теперь надо настроить DHCP, что бы интернет раздавался по локальной сети.

3G/4G модем

Инструкция схожа с динамическим подключением. Только надо выбрать другой интерфейс.

Если интернет не появится, то для начала активируйте модем стандартным образом на компьютере, а потом снова попробуйте поймать адрес как в инструкции выше.

Настройка L2TP/PPTP

PPPoE

Это частое подключение, когда интернет идёт от aDSL-модема. Напомню, что перед дальнейшими настройками первичный модем должен быть настроен и иметь мостовой режим работы как Bridge.

Статический IP

Для начала достаньте настройки от провайдера. Они должны быть в договоре. Там обязательно должны быть указаны: статический IP, маска, шлюз и DNS.

Всё интернет есть, для пущей уверенности можете зайти в терминал и проверить поддержку URL адресов. Для того можете вписать любой команду с известным вам адресом «ping google.com» или «ping yandex.ru». Но интернет есть только внутри этой нехитрой коробочки, чтобы он разлился и на другие устройства надо настроить DHCP.

Настройка DHCP сервер для локальных устройств

Эта штучка не только будет раздавать интернет, но также распределять IP адреса в автономном режиме.

Всё локальная сеть настроена и телефоны, планшеты, телевизоры и другие сетевые устройства смогут подключиться в единое сетевое пространство. Но интернета пока нет, остался последний так сказать штрих – настроить NAT.

Если говорить простым языком, то эта функция позволяет распределять интернет, между подключенными устройствами в локальной сети.

Ура, теперь интерн гуляет по проводам, но пока беспроводной режим не настроен. Осталось подправить конфиг WiFi сети и можно полноценно им пользоваться.

Mode: ap_bridge
Band: 2GHz-B/G/N
Channel Width: 20MHz
Frequency: 2412
SSID: тут будет название вашей сети;
Scan List: default;
Wireless Protocol:802.11
Security Profile: default;
WPS Mode: desabled;
Bridge Mode enabled;
VLAN Mode: no tag;
VLAN ID: 1

Установка пароля от администраторской панели

Видео инструкция

Источник

Настройка роутера Микротик

Сегодня поговорим про базовою настройку MikroTik для доступа в интернет. Данная инструкция написана как говорится для чайников так как все будем делать с нуля. Все настройки проводим на одном из популярных маршрутизаторов линейки, модели RB951G-2HnD. Все что тут описано подойдет к любому устройству, работающему на операционной системе RouterOS (то есть почти на все устройства Микротик).

Читайте также:  Как отразить в учете услуги по настройке программного обеспечения

Немного общей информации

MikroTik это – маршрутизаторы, коммутаторы, точки доступа и много другое оборудование которое выпускает Латвийская фирма. Больше всего она получила свою известность именно за недорогие и функциональные сетевые устройства.

Действительно, когда я первый раз начал его настраивать, первое что я сказал: «Ого и это все можно сделать на железки за 1500 рублей». Масштаб возможностей роутеров действительно поражает это и мультикаст, MPLS, огромное количество технологий VPN. Да он один может справится с работой небальной компании и филиалов, подключённых по pptp например.

Конечно есть и один минус, для неопытных пользователей настроить микротик с первого раза будет сложно. Для этого я и пишу данную статью.

Распаковка и сброс настроек

И так, к нам в руки попал один из роутеров, первым делом нам нужно установить на компьютер утилиту для настройки – mikrotik winbox. Через нее конфигурируются все роутеры данной фирмы, только коммутаторы используют для этих целей web-интерфейс (и то не все).

Подключаем наше устройства к сети «в любой порт кроме первого, так как на нем присутствует настройка по умолчанию, и он выделен под интернет» и запускает winbox. Теперь переходим на вкладку Neighbors (обнаружение) и подождем немного должно появится наше устройство. Нажимаем на mac адрес вводим логин по умолчанию «admin» и подключаемся.

После входа выводится окно «RouterOS Default Configuration» со стандартными настройками от производителя. Их стоит оставить только в том случае если вы дальше ничего настраивать не будете. Так как для новичка разобраться в них будет сложно, поэтому сбрасываем MikroTik нажав на кнопку «Remove Configuration».

Заметка! Полностью сбросить настройки также можно нажав и удерживая сзади устройства кнопку Reset или набрать в терминале system reset. Почитать об это можно тут. Теперь примерно через минуту он перезагрузится, и мы снова подключаемся к нему.

Настройка локальной сети

Первым делом давайте создадим локальную сеть для нашего офиса или дома. Особенностью микротик является то что все порты у него равны, то есть нет определенно выделенного порта под интернет, а другие под локалку. Мы можем сами выбирать как нам угодно, для этого есть механизм «Bridge». Простым языком Бридж это – объединение физических портов в пул логических (грубо говоря в один широковещательный домен). Замечу что Wi-Fi является тоже интерфейсов и если мы хотим, чтоб в нем была та же LAN сеть что и в портах, его также нужно добавить в Bridge.

В моем примере я сделаю WAN порт пятым, а все остальные объединим в бридж, и они будет в роли свитча.

Все настройки в данном месте у микротика можно оставить по умолчанию, на ваше усмотрение поменяйте название на более понятное, например, «bridge_lan». Переходим на следующую вкладку «port» и добавляем через кнопку плюс все порты кроме ether5.

Первый этап конфигурирования интерфейсов на уровне портов закончен, теперь у нас в ether1,2,3,4 и wlan1 единый широковещательный домен, а ether5 для подключения к провайдеру.

Настройка DHCP сервера и шлюза по умолчанию для LAN

В поле адрес вводим ту подсеть, которая вам нужна и выбираем интерфейс bridge1, после этого наш MikroTik будет доступен по этому адресу чрез объединённые порты и через wifi (который мы еще настроим).

Дальше чтобы все устройства в сети могли получать адреса автоматически мы переходим в раздел IP-> DHCP и собственно настраиваем его через кнопку «DHCP Setup». Выбираем интерфейс, на котором он будет работать «это наш bridge1», жмем Next и оставляем пространства адресов по умолчанию. В моем случае это будет подсеть в которой находится сам роутер. То есть раздавать микротик будет адреса с 192.168.9.2-192.168.9.255.

Читайте также:  Focusrite scarlett 2i2 настройка звука

После указываем адрес шлюза, который будут получат все подключенные устройства, так как это mikrotik оставляем значение по умолчанию.

В следующем окне перед нами встает выбор, раздавать ли весь диапазон адресов или его часть. По правильному лучше исключить первые 10 так как в будущем может появиться еще один роутер или коммутаторы которым желательно задать ip статикой. Но сейчас нам не принципиально, и мы оставляем как есть.

Наконец последним этапом указываем DNS. Если в вашей сети есть выделенный DNS сервер, то пишем его ip, если нет и вы настраиваете, например, для дома пишем ip самого роутера (в большинстве случаем так оно и будет).

Жмем далее, следующие значение не меняем. Все настройка DHCP сервера и шлюза по умолчанию на микротике закончена, переходим к следующему разделу.

Настройка интернета в микротик

Пришло время подключить наш роутер к провайдеру и настроить интернет. Вариантов это сделать масса, я расскажу о двух самых популярных:

Проверить правильность настройки можно тут же или в разделе IP-> Addresses, если получил ip то мы молодцы.

Вариант номер 2. Настройки от провайдера нужно ввести вручную, имеют они следующий вид:

Первое, указываем ip в том же разделе, как и при указании статического адреса. Только тут мы выбираем интерфейс ether5 – 192.168.1.104/24.

Конфигурирование провайдерского интернета закончено, давайте проверим все ли сделано правильно используя утилиту ping на ya.ru.

На этом настройка mikrotik не закончена, для того чтобы устройства из локальной сети могли выходить в интернет нужно еще сделать одну вещь.

Настройка NAT на Микротике

NAT это технология придуманная из-за нехватки ipv4, в дословном переводе означает «трансляция сетевых адресов». Простыми словами роутер будет подменять все запросы от локальной сети и отправлять их со своего ip. Дополнительный плюс — это закрывает внутреннюю сеть и защищает ее. Все ее настройки делаются в IP-> Firewall вкладка NAT. Добавляем правило:

Жмем ОК и на компьютерах в сети должен появится интернет. То есть они получат все необходимые настройки от микротока по DHCP, отработает NAT, DNS и запрос уйдет на шлюз по умолчанию. Но как же Wi-Fi?, его по-прежнему нет, сейчас мы это исправим.

Настройка wifi точки доступа на MikroTik

По правде сказать, Wi-Fi это очень объёмная тема, которую можно расписать на пару статей. Здесь же я покажу как быстро настроить wifi на микротике для домашних нужд или не большого офиса. Если же вам нужно разобрать во всем детальнее (ccq, ширина канала и т.д) то мы позже напишем статью и на эту тему.

По умолчанию wlan интерфейс выключен, поэтому идем и включаем его в разделе Wireless.

Далее надо настроить Security Profile – это место где мы задаем параметры безопасности для точки доступа.

Здесь закончили, сохраняем все и переходим в разделе Wireless на вкладку interfaces, двойным щелчкам открываем wlan1. Дальше указываем все так как у меня.

Здесь стоит обратить внимание на следующие параметры:

Такие значение как «Frequency» делайте как на скриншоте, это например частота канала. Ее по-хорошему нужно выбирать после анализа частотного спектра, но, если вы не знаете, что это ставьте любое значение, работать будет. На этом настройка роутера микротик с нуля закончена, можно пользоваться.

Шелкам правой кнопкой мышки на имя и выбираем поле «Password». В открывшемся окне собственно вводим и подтверждаем его. Всем пока надеюсь, что статья была полезной, оставляете свои вопросы в комментариях и вступайте в нашу группу Телеграмм (откроется новая страница в браузере – нажмите на кнопку открыть в Telegram).

89 вопросов по настройке MikroTik

Вы хорошо разбираетесь в Микротиках? Или впервые недавно столкнулись с этим оборудованием и не знаете, с какой стороны к нему подступиться? В обоих случаях вы найдете для себя полезную информацию в курсе «Настройка оборудования MikroTik». 162 видеоурока, большая лабораторная работа и 89 вопросов, на каждый из которых вы будете знать ответ. Подробности и доступ к началу курса бесплатно тут.

Источник