Меню

Настройка port channel cisco

ИТ База знаний

Полезно

— Онлайн генератор устойчивых паролей

— Онлайн калькулятор подсетей

— Руководство администратора FreePBX на русском языке

— Руководство администратора Cisco UCM/CME на русском языке

— Руководство администратора по Linux/Unix

Навигация

Серверные решения

Телефония

FreePBX и Asterisk

Настройка программных телефонов

Корпоративные сети

Протоколы и стандарты

Популярное и похожее

Настройка Site-To-Site IPSec VPN на Cisco

Настройка GRE туннеля на Cisco

Настройка Cisco Port-Security

Cisco IOS: сохранение конфигурации

Настройка EtherChannel на Cisco с минимальным даунтаймом

Фильтрация маршрутов в EIGRP

Внутреннее устройство маршрутизатора Cisco

Fanvil X6

Еженедельный дайджест

Настройка EtherChannel на Cisco

На самом деле EtherChannel это технология агрегации (объединения) каналов. Это означает, что мы можем объединить несколько линков в один логический, что позволит увеличить пропускную способность между коммутаторами.

Пример использования

Взглянем на схему ниже:

В рамках данной схемы мы имеем серверную инфраструктуру, которая подключена в коммутатору распределения (distribution switch) через свой коммутатор. За коммутатором распределения сидят коммутаторы доступы, за которым расположились пользовательские рабочие станции:

Если мы подключим два коммутатор линком в 1ГБ/сек, то потенциально, мы можем столкнуться с проблемой «бутылочного горлышка», то есть узкого места. Тогда пользователи испытают проблемы с доступом к серверной ферме.

Используя технологию EtherChannel, мы можем объединить до 8 интерфейсов (физических) в один логический линк (агрегация портов, Port-Channel) и трафик будет распределяться между физическими портами равномерно (балансируя нагрузку).

В нашем примере мы объединили 4 (четыре) гигабитных линка между рабочими станциями и серверами в один, с пропускной способностью 4ГБ/сек. Это увеличило общую пропускную способность и добавило отказоустойчивость линков!

Не забывайте про STP (Spanning-tree protocol). В случае агрегации портов, мы исключаем STP петли.

Режимы EtherChannel

Каждый из протоколов LACP или PAgP имеет по 3 режима работы, которые определяют режим его активности (инициализировать ли построение агрегации со своей стороны, или ждать сигнал с удаленной стороны):

Давайте посмотрим, в каком из случае будет установлено соединение EtherChannel при различных режимах настройки. Для LACP:

Теперь разберемся с PAgP:

Коммутатор №1 Коммутатор №2 Установится ли EtherChannel?
ON ON Да
DESIRABLE DESIRABLE/AUTO Да
ON/DESIRABLE/AUTO Not configured (off) Нет
ON DESIRABLE Нет
AUTO / ON AUTO Нет
Настройка

Ок, предположим, что порты с Gi0/0 по Gi0/3 буду использованы для агрегации EtherChannel. Лучше всего настроить логический интерфейс (агрегированный) в качестве транка, чтобы пропускать VLAN между коммутаторами.

Поднимаем LACP

В нашем случае switch1 будет активном (Active) режиме, а switch2 будет в пассивном (Passive) режиме.

Поднимаем PAgP
Полезные команды

Вот некоторые команды, которые могут понадобиться вам в работе с EtherChannel:

Полезно?

Почему?

😪 Мы тщательно прорабатываем каждый фидбек и отвечаем по итогам анализа. Напишите, пожалуйста, как мы сможем улучшить эту статью.

😍 Полезные IT – статьи от экспертов раз в неделю у вас в почте. Укажите свою дату рождения и мы не забудем поздравить вас.

Источник

Группировка портов на маршрутизаторе в channel-group

Рейтинг статьи: 2.407/5 (27 голосов).

Практически все, кто настраивал коммутаторы cisco знает о возможности объединения портов в channel-group, однако многие упускают из виду возможность объединения Ethernet портов на маршрутизаторах.

Спонсор этой страницы:

Объединяя порты на маршрутизаторе в группу мы увеличиваем безотказность работы.

Про увеличение пропускной способности в данном случае речь не идет, так как пропускная способность маршрутизации меньше чем пропускная способность даже одного канала.

channel-group на коммутаторе

interface Port-channel1
description Cisco 2821
switchport mode trunk
!
interface FastEthernet0/1
description Cisco 2821 G0/0
switchport mode trunk
channel-group 1 mode on
!
interface FastEthernet0/2
description Cisco 2821 G0/1
switchport mode trunk
channel-group 1 mode on

channel-group на маршрутизаторе

interface GigabitEthernet0/0
description G0/0 Channel Switch Fas 0/1
channel-group 1
!
interface GigabitEthernet0/1
description G0/1 Channel Switch Fas 0/2
channel-group 1

После данной манипуляции появляется интерфейс Port-channel1

Далее создаем подинтерфейсы, управляющие виланами

interface Port-channel1.100
description Po1.100 IT Departamet
encapsulation dot1Q 100
ip address 192.168.100.1 255.255.255.0
!
interface Port-channel1.101
description Po1.100 Manager Departamet
encapsulation dot1Q 101
ip address 192.168.101.1 255.255.255.0

И так далее, по аналогии с G0/0.100 и G0/1.101

Минусы данной схемы:

Первое: Оба порта приходят на один коммутатор, поэтому желательно прикупить коммутаторы с возможностью объединения в стек и использовать порты из разных коммутаторов. Например G1/0/1 и G2/0/1.

Второе: На маршрутизаторах ASR, ISR, при объединении портов в channel-group перестает работать service-policy на всех интерфейсах. Это баг IOS, который цискари еще не исправили. Cisco Bug: CSCuq10142

Третье: Сложно собраться с духом и изменить конфигурацию на работающей системе, тем более, если маршрутизатор в три-девятом царстве.

Если надумали что то менять, воспользуйтесь командой reload in 10, которая перезагрузит маршрутизатор через 10 мин., а если все получилось, то не забудьте дать команду reload cancel.

И пусть количество команд reload cancel будет равно количеству reload in 10.

Источник

Etherchannel на коммутаторах Cisco

Read the article CONFIGURING ETHERCHANNELS (LINK AGGREGATION) ON CISCO SWITCHES in English

Технология etherchannel (или port channel) позволяет из нескольких портов коммутатора (от 2 до 8) сделать один логический.
Эта технология используется для увеличения надежности соединения – трафик идет сразу по всем активным портам, а выход из строя любого физического порта никак не влияет на доступность всего соединения. Естественно, при использовании также увеличивается и скорость соединения

Важно!
Важно помнить, что подобные соединения возможно настроить только на портах с одинаковой пропускной способностью. Например на двух портах Fastethernet (100 + 100 Мбит/сек) или двух Gigabitethernet (1 + 1 Гбит/сек).
Нельзя объединить в один etherchannel интерфейсы Fastethernet (100Mb/s) и Gigabitethernet (1 Гбит/сек).

Важно!
Настройки etherchannel должны быть идентичными на обоих устройствах, которые соединяются подобным образом, будь то два коммутатора или коммутатор и сервер.

Для примера приведу настройки для соединения двух коммутаторов Cisco. Пусть это будут Cisco Catalyst 3560, хотя технология и синтаксис команды практически неизменен на всех моделях.

На первом коммутаторе SW-DELTACONFIG-1 необходимо создать логический интерфейс port-channel с уникальным порядковым номером (например 1)

SW-DELTACONFIG-1(config)#
interface port-channel1

Далее привязать к нему нужное количество физических портов. Не забудьте включить их командой no shut

SW-DELTACONFIG-1(config)#
interface Gi 0/1
channel-group 1 mode active
no shut

interface Gi 0/2
channel-group 1 mode active
no shut

Важно!
Я настоятельно рекомендую создавать подобные интерфейсы portchannel именно в такой последовательности:
— сначала сам логический интерфейс
— затем привязать его к физическим портам
— и уже после этого производить настройки логического интерфейса. Вся конфигурация переносится на физические порты автоматически.
Подобная последовательность исключит возможность ошибки в настройке, так как малейшее расхождение параметров ведет к некорректной работе всего portchannel.

Важно!
После включения физического интерфейса в логический на нем нельзя выполнять настройки. Любые изменения конфигурации производятся только (!) на логическом интерфейсе port-channel. Любое изменение на физическом порту коммутатора, включенного в port-channel ведет к выходу из строя всего агрегированного соединения.

На втором коммутаторе SW-DELTACONFIG-2 все настраивается аналогично. В примере оба коммутатора одинаковой модели Cisco Catalyst 3560 с идентичным набором интерфейсов. Поэтому отличия можно заметить только в поле description.

SW-DELTACONFIG-2(config)#
interface Gi 0/1
channel-group 1 mode active
no shut

interface Gi 0/2
channel-group 1 mode active
no shut

Проверка настроек

Помимо того, что стоит убедиться в наличии всех нужных строк в конфигурациях коммутаторов командой sh run, для проверки работы etherchannel используйте команду show etherchannel summary.

Number of channel-groups in use: 1
Number of aggregators: 1

Буквы P рядом с именами физических портов Gi 0/1 и Gi 0/2 означают, что интерфейсы функционируют исправно и входят в логическое подключение Portchannel 1. Символ D рядом с именем интерфейса будет означать, что интерфейс неактивен. Вероятнее всего стоить проверить соединение проводов и все настройки.

Важно!

Не забудьте сохранить конфигурацию на всех устройствах командой write или copy run start. Иначе после перезагрузки все изменения будут потеряны.
SWR-DELTACONFIG-1# write
Building configuration.
[OK]

Источник