Меню

Настройка микротик l2tp провайдера

Настройка L2TP Сервера на Mikrotik

Добрый день коллеги. Сегодня я покажу на деле как настроить L2TP Server на оборудовании Mikrotik. Конфигурация будет простая, без наворотов типа IPSEC. Но не стоит этим пренебрегать, т.к. стандартное шифрование весьма слабое и строить линки site-to-site без IPSEC я бы не рекомендовал.

Немного о протоколе L2TP

L2TP – протокол туннелирования второго уровня. Используется для поддержки виртуальных частных сетей. Отличительной особенностью, является, возможность работы не только в IP сетях, но и в ATM, X.25 и Frame Relay. Клиент-серверный протокол, всегда есть клиент и сервер. Использует на транспортном уровне UDP порт 1701 – большой плюс для трафика, которому не нужно подтверждение каждого пакета (IP телефония, видеонаблюдение), а значит работает быстрее. Но и в этом его минус, шифрование пакетов алгоритмом MPPE 128bit RC4 никого не напугаешь.

Конфигурирование

Используем наш уже знакомый лабораторный стенд с Mikrotik CHR версии 6.46.2 на борту. Мы находимся справа внизу в офисе SPB (Office-SPB).

Создание IP пула

На оборудовании Mikrotik есть нюанс с клиент серверными протоколами VPN – соединение не установится до тех пор, пока мы не назначим IP адреса с обоих сторон. Поэтому создадим пул для VPN клиентов. Подключаемся к московскому роутеру и открываем IP-Pool.

Добавляем пул, задаем имя и адреса.

Next Pool указывать не будем. Так же отмечу, что используем мы в VPN /32 маску подсети.

CLI:
/ip pool add name=L2TP-Clients ranges=172.16.25.2-172.16.25.10

Создание профиля подключения

Переходим к созданию профиля L2TP для нашего сервера. Создаем его в PPP – Profiles.

Создаем профайл. Указываем:

Переходим на вкладку Protocols, ставим значения:

Переходим в Limits, выставляем значение Only One в No.

Сохраняем и смотрим на результат.

CLI:
/ppp profile add change-tcp-mss=no local-address=172.16.25.1 name=L2TP-Server-General only-one=no remote-address=L2TP-Clients use-compression=yes use-encryption=yes use-mpls=no use-upnp=no

Включение L2TP сервера

Будем ориентироваться на повышение безопасности аутентификации и отключим старые протоколы. Если у вас есть устройства не поддерживающие современные протоколы аутентификации, то не забудьте включить их обратно. Переходим в PPP – Interface – L2TP Server.

Читайте также:  Тест гилева настройка пк на максимальную производительность

Выставляем следующее параметры:

Сохраняем и переходим далее.

CLI:
/interface l2tp-server server set authentication=mschap2 default-profile=L2TP-Server-General enabled=yes

Настройка firewall

Необходимо создать разрешающее правило входящего трафика L2TP на нашем mikrotik в firewall для UDP порта 1701. Приступим к реализации. IP – Firewall – Filter создаем новое правило.

В General нас интересует:

На вкладке Action нас интересует accept.

Сохраняем.

/ip firewall filter

add action=accept chain=input connection-state=new dst-port=1701 protocol=udp

add action=accept chain=input connection-state=established,related

На самом деле, данное правило будет работать только для новых пакетов пришедших на роутер, для остальных пакетов – нет, а значит сессия не оживет. Чтобы сессии жили и им было хорошо нужно еще одно правило, которое разрешает все устоявшиеся входящие соединения. Создаем еще одно правило.

На этом, пожалуй, все. Настройка сервера L2TP завершена.

Несколько слов про блокировку L2TP – из практики, есть такие товарищи — провайдеры, которые блокируют L2TP. Допустим Билайн в некоторых регионах уже начал блокировать весь L2TP без IPSEC. Обращайте на это внимание, если вы сделали все правильно, но соединение не проходит, значит дело в провайдере.

Далее мы рассмотрим настройку L2TP-клиента и конечно же всеми любимый IPSEC.

89 вопросов по настройке MikroTik

Вы хорошо разбираетесь в Микротиках? Или впервые недавно столкнулись с этим оборудованием и не знаете, с какой стороны к нему подступиться? В обоих случаях вы найдете для себя полезную информацию в курсе «Настройка оборудования MikroTik». 162 видеоурока, большая лабораторная работа и 89 вопросов, на каждый из которых вы будете знать ответ. Подробности и доступ к началу курса бесплатно тут.

Источник

настройка интернета l2tp на Mikrotik

Рекомендованные сообщения

Marat777 2

Marat777 2

У меня Mikrotik RB751u-2HnD интернет с ним работает, НО, не все сайты грузяться, а некоторые грузятся, но не полностью,

Читайте также:  Samsung настройка подключения к компьютеру

например Alixpress работает но в ЛК зайти нельзя.

Даже Вконтакте часто не подгружает некоторые фотки.

Данная проблема есть у многих на форумах, но точного ответа как все сделать, что бы работала я не нашел.

Интернет напрямую в комп работает хорошо, все грузиться.

Настраивал по этой инструкции

Она старовата, не актуальна, но работает, надо внести кое-какие изменения, а именно

MTU и пр настройки вбил как написано на офф билайн форуме

В общем, т.к. все микротики настраиваются одинаково т.к. это софтверный роутер и софт у всех одинаковый, уважаемая тех. поддержка,

сделайте, пожалуйста, инструкцию для Mikrotik, как заставить его полноценно работать.

Изменено 20 марта 2017 пользователем Marat777

Поделиться сообщением

Ссылка на сообщение
Поделиться на других сайтах

NikIv 992

уважаемая тех. поддержка,

сделайте, пожалуйста, инструкцию для Mikrotik

Этого роутера нет в списке поддерживаемых, по этому ваше желание реализовать не возможно.

Вы в этом разделе не пробовали поискать пути решения, по моему уже не раз поднимался подобный вопрос и не раз был ответ.

Изменено 20 марта 2017 пользователем NikIv

Поделиться сообщением

Ссылка на сообщение
Поделиться на других сайтах

 Ni©olas 159

Данная проблема есть у многих на форумах, но точного ответа как все сделать, что бы работала я не нашел.

на этом форуме есть решение. а также есть инструкции по настройке устройств.

Поделиться сообщением

Ссылка на сообщение
Поделиться на других сайтах

Marat777 2

Marat777 2

Почитал твою инструкцию, все ссылки, все сделал, версию Микротика обновил, но там кое чего не хватает! т.е. нужны доп. настройки и щас я тут их напишу.

Надеюсь кому-то поможет.

У меня инет по l2tp. Mikrotik RB751u-2HnD v.6.38.5.

2. делаем быструю настройку, придумайте себе название wi-fi сети, пароль.

А потом указываем этот параметр в DHCP клиенте, см. скрин, не забудте проверить параметр Add Default Route- YES

Читайте также:  Настройка пульта сигнализации pantera

Это что бы роутер принял маршруты от провайдера.

4. Создаем подключение, обратите внимание на MTU и MRU

5. открываем в микротике терминал и пишем комманду как на скрине- 2 раза!

7. и еще в консоли выполнить вот эту строчку

По этому правилу полно сработок.

И теперь у меня ВСЕ работает))

Изменено 20 марта 2017 пользователем Marat777

Источник

Настройка MikroTik hap lite на работу с Beeline

Настройка MikroTik на работу с провайдером Beeline

Настройка MikroTik на работу с провайдером Beeline через L2TP

2. Далее производим полный сброс устройства:

4. Далее убедимся что работает dhcp client и роутер получил настройки локальной сети Beeline.

5. Выясним ip адрес шлюза в сети билайн, он необходим для выполнения маршрутов в которых находятся DNS и VPN сервера, переходим в IP-Routes.

6. Создадим новый статический маршрут к DNS серверам. Нажимаем на (+) и вводим подсеть которую узнали из 4 пункта, 213.132.75.0/24, шлюз прописываем 10.44.232.1 из пункта 5.

7. У билайн есть особенность он не отдает маршрут до VPN сервера микротиковскому клиенту, но дает его windows клиенту, поэтому нам надо либо подключить провод билайн напрямую к компьютеру, либо проделать следующую работу: отключаем локальный DHCP сервер и добавляем первый порт роутера в бридж.

8. Далее надо переподключить локальную сеть, тогда мы увидим что получили ip адрес от dhcp сервера билайн на ПК.

9. Нам надо запустить командную строку windows и определить адреса VPN серверов, для этого вводим в командную строку nslookup tp.internet.beeline.ru

11. В качестве Remote Address билайн нам даст адрес VPN сервера что приведет к нарушениям маршрутизации через тоннель, заменем Remote Address на адрес из локальной подсети

12. Идем во вкладку Interface и создаем новый интерфейс L2tp

13. Теперь надо настроить NAT чтобы интернет был не только у MikroTik hap lite. Заходим в IP—Firewall и жмем (+).

Источник

Adblock
detector