Меню

Настройка frame relay коммутатора

Packet Tracer: Конфигурирование Frame Relay с подынтерфейсами «точка-точка»

Исходные данные и указания

Четыре маршрутизатора должны быть связаны в виде звездообразной Frame Relay архитектуры (hub-and-spoke Frame Relay configuration), в которой R1 должен быть центром (hub) звезды, а маршрутизаторы R2, R3, и R4 – ее лучами (spoke routers). Frame Relay соединения должны устанавливаться с применением соединения типа point-to-point от подынтерфейсов R1 до каждого spoke маршрутизатора. Маршрутизация будет строиться с использованием статических маршрутов на hub маршрутизаторе и маршрутов по умолчанию на всех spoke маршрутизаторах. Frame Relay коммутатор(ы) уже сконфигурирован(ы) в пределах облака (cloud).

Удаленный административный доступ с применением SSH доступен с логином admin и паролем cisco.

Задача 1: Конфигурирование Frame Relay и статических маршрутов на концентраторе Router (R1).

Шаг 1. Проверка исходной конфигурации.

Примечание: Все маршрутизаторы должны быть сконфигурированы под своим именем, иметь enable пароль и настроены на SSH-соединение. Все LAN интерфейсы должны иметь IP адреса и находиться в работоспособном состоянии.

Шаг 2. Конфигурирование физического Frame Relay интерфейса на R1.

R1(config-if)# encapsulation frame-relay

Шаг 3. Конфигурирование подынтерфейсов на R1.

SM: 255.255.255.252 DLCI: 102 S0/0/0.103 IP: 10.0.1.5

SM: 255.255.255.252 DLCI: 103 S0/0/0.104 IP: 10.0.1.9

SM: 255.255.255.252 DLCI: 104

R1(config)# interface Serial0/0/0.102 point-to-point

R1(config-subif)# ip address 10.0.1.1 255.255.255.252

R1(config-subif)# frame-relay interface-dlci 102

R1(config)# interface Serial0/0/0.103 point-to-point

R1(config-subif)# ip address 10.0.1.5 255.255.255.252

R1(config-subif)# frame-relay interface-dlci 103

R1(config)# interface Serial0/0/0.104 point-to-point

R1(config-subif)# ip address 10.0.1.9 255.255.255.252

R1(config-subif)# frame-relay interface-dlci 104

Шаг 4. Конфигурирование на R1 статических маршрутов к подсетям всех трех spoke маршрутизаторов.

R1(config)# ip route 10.30.30.0 255.255.255.0 10.0.1.6

R1(config)# ip route 10.40.40.0 255.255.255.0 10.0.1.10

Задача 2: Конфигурирование Frame Relay и маршрута по умолчанию на spoke маршрутизаторах.

Шаг 1. Конфигурирование физического Frame Relay интерфейса на spoke маршрутизаторах.

R2(config-if)# encapsulation frame-relay

Шаг 2. Конфигурирование подынтерфейса на R2.

R2(config)# interface Serial0/0/0.101 point-to-point

R2(config-subif)# ip address 10.0.1.2 255.255.255.252

R2(config-subif)# frame-relay interface-dlci 101

Шаг 3. Конфигурирование маршрута по умолчанию на R2.

Шаг 4. Повторите шаги 1 – 3 на R3 и R4.

R3(config-if)# encapsulation frame-relay

R3(config-if)# no shutdown

R3(config)# interface Serial0/0/0.101 point-to-point

R3(config-subif)# ip address 10.0.1.6 255.255.255.252

R3(config-subif)# frame-relay interface-dlci 101

R4(config-if)# encapsulation frame-relay

R4(config-if)# no shutdown

R4(config)# interface Serial0/0/0.101 point-to-point

R4(config-subif)# ip address 10.0.1.10 255.255.255.252

R4(config-subif)# frame-relay interface-dlci 101

Задача 3: Проверка соединения.

Шаг 1. Проверка Frame Relay сети.

Serial0/0/0.102 (up): point-to-point dlci, dlci 102, broadcast, status defined, active

Serial0/0/0.103 (up): point-to-point dlci, dlci 103, broadcast, status defined, active

Serial0/0/0.104 (up): point-to-point dlci, dlci 104, broadcast, status defined, active

Шаг 2. Проверка соединения с spoke сетями.

Шаг 3. Проверка результатов.

Задача 4. Проверка функционирования web сервиса в сети.

Шаг 1. Добавление хостов к подсетям.

Шаг 2. Проверка соединения.

Шаг 3. Проверка маршрутов.

Шаг 4. Проверка web сервиса.

С одного из хостов (PC1–PC3) в адресной строке браузера наберите адрес Web сервера (www.mycom.com).

Варианты для отработки пропусков по данной теме

Исходный вариант данной работы находится на сайте Personal Site of Engr. Glenn Ople Avendano

Источник

Frame Relay — пример настройки и описание

Frame Relay – WAN-протокол, работающий на втором уровне модели OSI, то есть, там же, где работают Ethernet, PPP, HDLC и др. Frame Relay пришёл на смену протокола X.25, в России сравнительно широкого распространения не получил, а сейчас – и вовсе его время давно прошло. Знания этого протокола могут потребоваться, если вы работаете у провайдера, у которого по старой памяти остались какие-то абоненты, работающие по FR. Кроме того, знание Frame Relay помогает в понимании MPLS.

Читайте также:  Настройка дбо bs client v 3

Принципы работы Frame Relay

Аналогично другим WAN протоколам мы, как клиент, настраиваем маршрутизатор как DTE. В качестве DCE выступает провайдерское оборудование, а именно, коммутатор FrameRelay switch. В качестве такого коммутатора может выступать обычный маршрутизатор cisco и пусть слово «коммутатор» вас не смущает. В этой статье я не буду останавливаться на терминологии WAN, большую часть материала можно прочитать в статье «Что такое clock rate, DCE и DTE?».

Как используется Frame Relay? Мы арендуем у провайдера виртуальную сеть для соединения двух удалённых подразделений, он даёт нам кабель и говорит: настройте у себя на маршрутизаторе Frame Relay и добавляет: «Чтобы попасть из офиса А в офис Б используется DLCI 102, чтобы попасть из офиса Б в офис А используется DLCI 201»

DLCI – это «Data Link Connection Identifier», идентификатор соединения. У провайдера есть большая сеть, через которую проходит множество разных соединений (Virtual Circuit-ов), каждое направление по каждому из них имеет свой идентификатор – DLCI. Причём, DLCI имеет локальное значение, так что, если смотреть на приведённый рисунок, то первый же Frame Relay коммутатор «А», получив фрейм с DLCI 201 вполне может поменять его на другое значение, так как само число 201 имеет смысл только в контексте маленького участка сети между двумя соседними коммутаторами. Благодаря этому одни и те же номера DLCI можно использовать в разных частях сети, главное, чтобы все настройки на коммутаторах были согласованы между собой. DLCI Фактически это адрес канального уровня, то есть для Frame Relay DLCI – это способ идентификации общающихся устройств, как, например, MAC адрес для Ethernet. Только тут речь идёт скорее не об устройствах, а о каналах. В общем всё это для общего развития, а практически надо знать одно, с каждого из наших устройств, на границе облака, до каждого другого (до которого мы арендовали сеть от этого) ведёт один конкретный DLCI, который нам надо настроить.

Структура кадра Frame Relay

Кадр FR имеет следующий формат:

Для того, чтобы отправить что-то через сеть, надо, чтобы маршрутизатор знал, что его ждёт за тем или иным DLCI-ем, на том конце линии. Иными словами, необходима таблица соответствия DLCI-ев и IP адресов роутеров, находящимися за ними. Такая таблица называется frame relay map, она может строиться автоматически или настраиваться вручную администратором. С некоторой натяжкой можно провести аналогию между frame relay map и arp таблицей в Ethernet, так как в обоих случаях таблица нужна для установления соответствия между адресами протоколов второго и третьего уровней. Для автоматического создания таблицы есть протокол Inverse ARP – он позволяет, зная номер DLCI, узнать ip адрес маршрутизатора, находящегося на том конце соответствующего этому DLCI маршрута.

Frame Relay сам по себе занимается только доставкой данных. Однако, у него есть расширение LMI – Local management interface, которое позволяет, например, автоматически получать от провайдера список открытых для нас DLCI, через него же работает и Inverse ARP. Технически LMI помещает служебную информацию в поля ADDRESS и DATA обычного Frame Relay фрейма.

Настройка Frame Relay на маршрутизаторе

В CCNA рассматривается два способа настройки Frame Relay: с сабинтерфейсами и без. Второй способ проще, но через него не будет работать динамическая маршрутизация. Поэтому он может использоваться либо при соединениях точка-точка, либо, если вы знаете, что делаете.

Имеется топология, давайте попробуем настроить двумя способами.

Настройка без сабинтерфейсов

Пусть провайдер нам сообщил номера DLCI:

IP адреса маршрутизаторов:

Настройка без сабинтерфейсов – все DLCI-и выходят наружу с нашего маршрутизатора через один общий serial интерфейс.

Читайте также:  Nokia lumia 530 возврат к заводским настройкам

Настройка достаточно простая: мы указали включили интерфейс, настроили инкапсуляцию и ip адрес, с помощью bandwith сообщили маршрутизатору реальную скорость канала (чтобы потом, например, метрика правильно считалась) и добавили две строчки в карту framerelay, сообщив, что 192.168.0.2 находится за DLCI-ем 102, а 192.168.0.3 – за 103. Слово broadcast означает в данном контексте вот что: Сам FR не поддерживает широковещательный трафик, но если мы задаём это слово, то при необходимости отправки брудкаста, он будет заменён на множество юникастовых фреймов – для всех получателей. Без этого слова не будут работать, например, протоколы динамической маршрутизации.

Аналогично настраиваем R3:

Настройка с сабинтерфейсами

Теперь попробуем реализовать то же самое, но с сабинтерфейсами. Отличие этого способа в том, что для каждого DLCI создаётся отдельный сабинтерфейс. Это нужно для работы протоколов динамической маршрутизации. Дело в том, что в динамической маршрутизации есть правило Split horizon, которое означает, что маршрутизатор не сообщает про некую сеть через тот же интерфейс, откуда он про неё узнал. То есть, если настраивать без сабинтерфейсов и R2 сообщит про какую-то сеть для R1, то R1 не сможет про неё рассказать дальше роутеру R3, так как он узнал про эту сеть с интерфейса s0/0/0, он не может через него же про неё сообщить. В случае использования сабинтерфейсов проблема решается, так как R1 узнал про эту сеть через интерфейс s0/0/0.102, а сообщил через s0/0/0.103. В этой топологии разные DLCI находятся на разных сабинтерфейсах, а значит надо поменять и ip адресацию чтобы не получилось, что у маршрутизатора два интерфейса в одной и той же сети.

Пусть сети будут такие:

Как и при создании сабинтерфейсов для работы с VLAN, сам номер сабинтерфейса не говорит ничего о номере DLCI для связывания с DLCI используется команда frame-relay interface-dlci. Но с точки зрения удобства и понятности, лучше делать номер сабинтерфейса совпадающим с номером DLCI.

К статье прилагаю два примера: настройка без сабинтерфейсов и с сабинтерфейсами.

Источник

Настройка и устранение неполадок Frame Relay

Параметры загрузки

Интерактивный: В данном документе представлен анализ конкретного устройства Cisco.

Содержание

Общие сведения

Обратите внимание, что адреса Q.922, как видно из схемы, представляют собой два октета и содержат 10-битный идентификатор каналов передачи данных (DLCI). В некоторых сетях адреса Q.922 могут быть увеличены до 2 или 3 октетов.

10-битное значение DLCI является основным компонентом заголовка Frame Relay. Оно определяет логическое соединение, которое уплотняется в физический канал. В стандартном режиме адресации (т.е. не дополненным интерфейсом локального управления (LMI)) идентификаторы DLCI имеют локальное значение; т.е. конечные устройства с обеих сторон соединения могут использовать разные DLCI для обращения к одному и тому же соединению.

Перед началом работы

Условные обозначения

Для получения дополнительных сведений обратитесь к разделу Условные обозначения технических терминов Cisco.

Предварительные условия

За более подробной информацией о терминах, используемых в данном документе, обратитесь к разделу Глоссарий по Frame Relay.

Используемые компоненты

Данный документ не ограничен отдельными версиями программного и аппаратного обеспечения.

Данные для документа были получены в специально созданных лабораторных условиях. При написании данного документа использовались только устройства с пустой (стандартной) конфигурацией. В рабочей сети необходимо изучить потенциальное воздействие всех команд до их использования.

Теоретические основы

Изначально протокол Frame Relay предназначался для использования в интерфейсах ISDN. Первые предложения по такому использованию были поданы в сектор стандартизации международного союза телекоммуникаций (ITU-T) (ранее международный консультативный комитет по телеграфной и телефонной связи [CCITT]) в 1984 году. Разработка Frame Relay велась также в комитете по стандартам T1S1 (аккредитованным ANSI) в США.

Читайте также:  Настройка ресивера gi phoenix

В 1990 году компании Cisco Systems, StrataCom, Northern Telecom и Digital Equipment Corporation образовали консорциум для разработки технологии Frame Relay и продвижения совместимых с Frame Relay продуктов. Они не только разработали спецификацию, соответствующую основному протоколу Frame Relay, который обсуждался в T1S1 и ITU-T, но и дополнили ее новыми функциональными возможностями для работы в сложных сетях. Новые возможности Frame Relay называют интерфейсом локального управления LMI. Этот интерфейс локального управления в маршрутизаторе выпускается под маркой «cisco» в противоположность аналогичному интерфейсу «q933a» или «ansi».

Frame Relay существенно отличается от X.25 по функциональности и формату. В частности, протокол Frame Relay, обеспечивая более высокую производительность и эффективность, является более совершенным.

Являясь связующим интерфейсом между пользователем и сетевым оборудованием, Frame Relay обеспечивает статистическое мультиплексирование нескольких логических соединений (виртуальных каналов) через один физический канал передачи данных. В этом состоит отличие Frame Relay от систем, использующих только метод мультиплексирования с разделением по времени (TDM) для работы с несколькими потоками данных. Статистическое мультиплексирование протокола Frame Relay обеспечивает более гибкое и эффективное использование доступной полосы пропускания. Его можно использовать без технологии TDM или в верхней части каналов связи в системе TDM.

Еще одна важная характеристика Frame Relay состоит в использовании прежних достижений технологии передачи данных широкомасштабных сетей (WAN). Раньше протоколы WAN, такие как X.25, разрабатывались преимущественно на аналоговых системах передачи данных с медными носителями. Такие каналы менее надежны, чем современные цифровые оптоволоконные каналы передачи данных. В них протоколы на уровне канала могут опережать алгоритмы исправления ошибок, требующие большого количества времени; исправление ошибок осуществляется на более высоких уровнях протокола. Поэтому, более высокая производительность и эффективность достигается без нарушения целостности данных. Этот принцип лежал в основе создания Frame Relay. Он включает в себя алгоритм цикличной проверки избыточности (CRC) для обнаружения поврежденных битов (таким образом, данные могут быть отклонены), но не содержит механизмов для восстановления поврежденных данных (например, с помощью повторной передачи данных на этот же уровень протокола).

Еще одно различие между Frame Relay и X.25 состоит в отсутствии в протоколе Frame Relay определенного способа управления потоками для каждого виртуального канала. Сегодня многие протоколы верхнего уровня эффективно используют свои собственные алгоритмы управления потоками данных, поэтому необходимость в наличии этой функции на уровне канала практически отсутствует. Поэтому протокол Frame Relay не содержит конкретных процедур управления потоками данных, которые бы дублировали аналогичные процедуры на более высоких уровнях. Напротив, протокол содержит механизмы уведомления о перегрузке, которые информируют пользователя сети о приближающейся перегрузке сетевых ресурсов. При наличии такого уведомления протоколы более высокого уровня могут получить сигнал о необходимости управления потоками данных.

Настройка базовой технологии Frame Relay

Планирование настройки Frame Relay можно начинать при наличии надежного соединения с локальным коммутатором Frame Relay на обоих концах постоянного виртуального канала (PVC). В первом примере по умолчанию используется «Сisco» интерфейс локального доступа (LMI) на основе Spicey. По умолчанию это интерфейс многоточечного («multipoint») соединения, поэтому включена функция frame-relay inverse-arp (для двухточечного соединения Inverse ARP отсутствует). Для инкапсуляции Frame Relay функция проверки расщепленного горизонта IP по умолчанию отключена, поэтому обновления маршрутизации приходят и выходят из одного и того же интерфейса. Маршрутизаторы запоминают необходимые идентификаторы канала связи (DLCI), которые они затем используют для получения сигналов от коммутатора Frame Relay через обновления LMI. Затем они инверсируют ARP для удаленного адреса IP и создают карту отображения локальных DLCI и связанных с ними удаленных IP-адресов.

Источник

Adblock
detector