Меню

Cisco 2960 настройка putty

Начальная настройка cisco через COM-порт

Начальная настройка cisco через COM-порт

Всем привет сегодня хочу освежить в памяти как производится начальная настройка cisco через COM-порт. Когда вы получаете новое оборудование, оно как правило имеет заводские настройки, которые врят ли кому подходят, в том числе и Cisco. Единственным способом осуществить первоначальную настройку, хотя бы назначить ip адрес и включить ssh для удаленного доступа, является подключение через COM-порт, в комплекте всегда идет специальный голубой провод.

Схема подключения и оборудование Cisco

И так базовая настройка cisco начинается, вот как выглядит схема подключения COM-портом к нашему сетевому оборудованию.

С одной стороны на сетевом оборудовании есть консольный порт вида мини USB либо формата RJ45.

Вот как выглядят фирменные провода для подключения через console port cisco. Кстати новый оригинальный голубой провод стоит 15 баксов.

Если у вас например ноутбук или стационарный компьютер не имеют разъема на материнской плате для COM-порт, то есть переходники COM-порт to USB.

Настройки COM-порта

Настройки COM-порта для подключения к Cisco можете посмотреть по данной ссылке, я ранее делал себе заметку из них самое главное это:

Подключаться я буду через терминал в Cisco packet tracer 6.4, но и покажу как это происходит и через всем известную putty.

В putty базовая настройка cisco, начинается с вкладки Serial, тут нужно убедиться, что все настройки выставлены как я показывал вам выше.

Далее идем на вкладку Session и выбирем Serial, в поле Serial Line укажите нужный Com port.

Если не знаете какой у вас Com порт используется, то делаете следующее, нажимаете Win+R и вводите devmgmt.msc, у вас откроется диспетчер устройств.

И в пункте Порты (COM и LPT) смотрим ваши номера.

Вы попадаете в терминальную сессию, первым делом нужно удалить стартовый конфиг, делается это просто:

Все теперь ваше устройство не содержит ни каких настроек и при первой загрузке вы получаете стандартный мастер настройки System Configuration Dialog, я если честно всегда говорю нет и привык делать все в ручную, на мой взгляд это нужно уметь делать, если вам вдруг нужно вызвать меню мастера первоначальных настроек, то это делается командой setup.

Команды в терминале Cisco

Такое малое количество команд означает,ч то мы находимся в обычном режиме терминала, попасть в привилегированный режим вводим

как видите, список команд существенно увеличился.

Зададим время clock set 13:53:00 28 nov 2016, у вас конечно оно будет своим, более детально как делается настройка времени cisco читайте по ссылке. Зададим dns имя вашему устройству, для этого заходим в режим настройки:

hostname и пишите нужное вам имя

и зададим домен ip domain-name и нужное имя домена

Следующим шагом нужно установить пароль на привилегированный режим в Cisco, а так же создать нового пользователя с возможностью логиниться из локальной базы. Далее настраиваем статический IP адрес и ssh или telnet доступ. После чего можно открывать у себя Putty и спокойно цепляться по удаленке, чтобы продолжить настройку Cisco так как вам это нужно. Надеюсь вы не уснули)))

Источник

Простейшая настройка коммутатора Cisco 2960

Read the article BASIC CONFIGURATION OF CISCO 2960 SWITCH in English

Требуется организовать следующие сети (Vlan):

— отдел продаж (192.168.10.0 255.255.255.0)
— бухгалтерия (192.168.20.0 255.255.255.0)
— администраторы (192.168.100.0 255.255.255.0)
— сеть для управления сетевым оборудованием (192.168.1.0 255.255.255.0)

Видео версия этой статьи на английском языке.

Читайте также:  Dir 320 настройка ipoe

Для справки:
Устройства 2го уровня способны передавать данные только внутри одной сети и осуществляют передачу на основе информации о MAC адресах (например внутри сети 192.168.0.0 /24).

Устройства 3го уровня (например коммутатор Cisco 3560) способны маршрутизировать данные на основе информации об ip адресах и передавать их между различными сетями (например между сетью 192.168.1.0 /24 и сетью 192.168.2.0 /24).

Шаг 0. Очистка конфигурации

(Выполняется только с новым или тестовым оборудованием, так как ведет к полному удалению существующей конфигурации)

После извлечения коммутатора из коробки, подключаемся к нему с помощью консольного кабеля и очищаем текущую конфигурацию, зайдя в привилегированный режим и выполнив команду write erase. (Подробнее о режимах конфигурирования оборудования Cisco можно прочитать в этой статье)

Switch> enable
Switch# write erase
/подтверждение очистки конфигурации/
Switch# reload
/подтверждение/
После выполнения коммутатор должен перезагрузиться в течение 3ех минут, а при старте вывести запрос о начале настройки. Следует отказаться.
Would you like to enter the basic configuration dialog (yes/no): no

Шаг 1. Имя коммутатора

Присвоим коммутатору имя SW-DELTACONFIG-1. (SW – сокращение названия SWitch) Для этого зайдем в режим конфигурирования и введем следующие команды:

Switch #conf t
Enter configuration commands, one per line. End with CNTL/Z.
Switch (config)# hostname SW-DELTACONFIG-1
SW-DELTACONFIG-1 (config)#
Название устройства изменилось со «Switch» на «SW-DELTACONFIG-1».

Шаг 2. Интерфейс для удаленного управления

Настраиваем интерфейс для управления коммутатором. По умолчанию это Vlan 1. Для этого присваиваем ip адрес интерфейсу и включаем его командой no shutdown.

SW-DELTACONFIG-1(config)#
interface vlan 1
ip address 192.168.1.11 255.255.255.0
no shutdown
В дальнейшем коммутатор будет доступен именно под адресом 192.168.1.11

Шаг 3. Авторизация пользователей

Настраиваем авторизацию для доступа к устройству. Для этого задаем пароль доступа к привилегированному режиму (знак # рядом с названием устройства), а также создаем учетную запись пользователя и пароль для удаленного подключения.

Задаем пароль для доступа к привилегированному режиму #
SW-DELTACONFIG-1(config)#
enable secret XXXX

Создаем учетную запись для удаленного управления и пароль для нее
username admin secret YYYYY

Включение авторизации, с использованием локальной базы данных пользователей и паролей
SW-DELTACONFIG-1(config)#
line vty 0 4
login local

Для проверки доступности enable режима (#) после ввода этих команд выходим из всех режимов конфигурирования (командой exit или буквой Q в каждом из режимов или сочетанием клавиш Ctrl+Z), оказываемся в первоначальном режиме (обозначается знаком >) и пробуем вновь зайти в привилегированный режим (обозначается знаком #). На запрос пароля вводим тот, который только что задали.

Если ничего не напутали, то видим примерно следующее:
SW-DELTACONFIG-1>enable
Password: XXXXX
SW-DELTACONFIG-1#

После того, как убедитесь, что устройство доступно по протоколу Telnet рекомендую настроить защищенный доступ по протоколу SSH. Подробные инструкции приведены в этой статье.

Шаг 4. Создание Vlan

Создаем Vlan для каждого из отделов и присваиваем им порядковые номера и названия.
SW-DELTACONFIG-1(config)#
vlan 10
name NET_SALES
vlan 20
name NET_ACCOUNT
vlan 100
name NET_ADMIN

Сеть Vlan 1 всегда присутствует на коммутаторе по умолчанию. Она будет использоваться для удаленного управления.

Убеждаемся, что все созданные нами сети присутствуют в списке.

Шаг 5. Привязка портов

Соотносим порты доступа коммутатора (access port) нужным сетям. На коммутаторе из примера 24 порта FastEthernet и 2 порта Gigabit Ethernet. Для подключения пользователей будут использоваться только Fast Ethernet.

Распределим их следующим образом:

На каждом интерфейсе для удобства дальнейшего администрирования добавим примечания командой description. Это обычное текстовое поле, которое никак не влияет на другие настройки.
SW-DELTACONFIG-1(config)#
interface range fa 0/1 – 6
switchport access vlan 100
description NET_ADMIN
interface range fa 0/7 – 18
switchport access vlan 10
description NET_SALES
interface range fa 0/19 – 24
switchport access vlan 20
description NET_ACCOUNT

Читайте также:  Настройка ввода языка виндовс 10

Введенными командами мы разделили один физический коммутатор на 4 логических (Vlan 1, Vlan 10, Vlan 20 и Vlan 100).

Важно!
Взаимодействие без использования маршрутизатора будет осуществляться только(!) между портами, принадлежащими одному и тому же Vlan.
Рабочие станции, подключенные в порты, принадлежащие разным Vlan, не смогут взаимодействовать друг с другом даже если будет настроена адресация из одной сети.

Для взаимодействия всех 4ех сетей необходим маршрутизатор, подключенный к коммутатору с помощью trunk порта. Инструкцию по настройке вы найдете здесь. Отличие trunk интерфейса в том, что при передаче по нему трафика каждый пакет помечается номером Vlan, которому принадлежит. Это позволяет устройствам правильно перенаправлять пакеты. На самом коммутаторе порт настраивается следующим образом:
SW-DELTACONFIG-1(config)#
interface GigabitEthernet 0/1
switchport mode trunk
switchport trunk encapsulation dot1q

Если система не принимает последнюю строчку, то это значит, что режим dot1q – единственно возможный, и он настроен по умолчанию.

После выполнения всех описанных действий для проверки подключите две рабочие станции в порты, принадлежащие одному Vlan, например с номером 100, установите на них ip адреса 192.168.100.1 и 192.168.100.2, после чего запустите ping с одной из них на другую. Успешный ответ означает, что все работает как нужно.
Для справки:
Существуют модели коммутаторов 3го уровня модели OSI (Например Cisco 3560), которые объединяют в себе функции коммутатора 2го уровня (access или уровня доступа) и маршрутизатора (устройства 3го уровня). Устройства 3го уровня используются для передачи данных между различными сетями и руководствуются информацией об ip адресах.

Решение аналогичной задачи организации нескольких Vlan на таком коммутаторе рассмотрено в этой статье)

Важно!

Не забудьте сохранить конфигурацию на всех устройствах командой write или copy run start. Иначе после перезагрузки все изменения будут потеряны.
FW-DELTACONFIG-1# write
Building configuration.
[OK]

Источник

Базовая настройка коммутатора Cisco Catalyst

В этой статье я хочу вас познакомить с настройками, с которыми сталкивается любой сетевой инженер, это базовые настройки устройства. Более конкретно рассмотрим базовую настройку коммутатора Cisco Catalyst. В моем примере это Cisco Catalyst 2950, однако базовые настройки для коммутаторов различных платформ одинаковы.

Собираем топологию, как на рисунке.

Для этого нам понадобится rollover-консольный кабель. Подключаем один конец rollover-консольного кабеля к консольному порту RJ-45 на коммутаторе. Другой конец кабеля подключаем к последовательному COM-порту на компьютере. Если на компьютере отсутствует последовательный COM-порт, то вам понадобиться USB–Serial (DB9) переходник. При использовании USB–Serial (DB9) переходника для подключения rollover-консольного кабеля может потребоваться установка драйвера. Его можно скачать с сайта производителя USB–Serial (DB9) переходника. Также нам понадобится знать номер COM-порта для того, чтобы выполнить подключение, его можно посмотреть через Диспетчер устройств после подключения переходника.

Самый лучший переходник USB–Serial (DB9), которым мне довелось пользоваться, это PL2303 фирмы Prolific Technology Inc. Для этого переходника доступны драйвера для всех популярных операционных систем.

Запускаем программу эмуляции терминала — PuTTy. Указываем номер COM-порта, указываем настройки подключения как на рисунке и нажимаем на кнопку Open.

Также необходимо соединить компьютер обычным прямым (straight-through) патч-кордом с портом FastEthernet 0/1 коммутатора, как показано на рисунке.

Читайте также:  Как найти настройки в новой версии скайп

Итак начнем, включаем питание. Устройство выполняет Power-On-Self-Test (POST) — самотестирование, после чего идет загрузка операционной системы Cisco IOS. В моем случае устройство сброшено к заводским настройкам и на нем нет файла начальной конфигурации (startup-config). При загрузке вы должны увидеть что-то такое:

Если загрузка прошла штатно, то вы должны увидеть приглашение в конфигурационный диалог, мы здесь отвечаем no, потому что будем сами все настраивать.

Собственно после этого мы попадаем в командную строку, где и будем выполнять базовую настройку.

Далее нужно убедиться в том, что коммутатор действительно сброшен к заводским настройкам:

Изначально мы попадаем в пользовательский режим user EXEC. Он имеет ограниченные возможности. Этот режим выглядит таким образом:

Переключаемся в привилегированный режим privileged EXEC, для этого нужно ввести команду:

Переключаемся в режим глобальной конфигурации, для этого вводим команду:

Необходимо задать имя устройству:

Здесь мы указали имя коммутатору switch-floor-1. Рекомендую задавать имя для устройства логично, чтобы потом не перепутать и было через время очевидно, что это за устройство и где оно находится.

Обязательно задаем пароль на привилегированный EXEC режим:

Запрещаем нежелательный поиск в DNS:

Задаем баннероное сообщение MOTD, которое будет выводиться перед входом в систему:

Обратите внимание, что здесь открывающий символ для сообщения это # (решетка), соответственно нужно обязательно баннерное сообщение заканчивать этим знаком # (решетка).

Проверяем настройки доступа. Для этого переключаемся между режимами:

Примечание. Пароль не будет отображаться на экране во время ввода.

Обеспечим возможность удаленного управления коммутатором, для этого необходимо настроить IP-адрес на Switch Virtual Interface (SVI). Перейдем в режим глобальной конфигурации и далее в SVI:

Ограничим доступ к консольному порту. Конфигурация по умолчанию разрешает все консольные подключения без пароля:

Здесь мы задаем пароль для пяти одновременных подключений, в Cisco IOS диапазон указывается через пробел.

Далее настроим IP-адрес на компьютере:

Должно получиться как-то так:

Теперь посмотрим настройки коммутатора:

Проверяем состояние интерфейса управления SVI. Состояние интерфейса VLAN 1 должно быть up/up, что указывает на то, что он активен, и ему должен быть назначен IP-адрес. Обратите внимание, что состояние порта коммутатора FastEthernet0/1 — тоже up, так как к нему подключен компьютер. Поскольку все порты коммутатора изначально принадлежат VLAN 1 по умолчанию, вы можете взаимодействовать с коммутатором по IP-адресу, который был назначен для VLAN 1.

Протестируем подключение между компьютером и коммутатором. Открываем окно командной строки (cmd.exe) на компьютере. В командной строке пишем команду ipconfig для того, чтобы посмотерть сведения об IP-адресе.

Там же в командной строке вводим команду ping, которая используется для проверки подключения.

Обратите внимание, что первый тест прошел неудачно, мы видим сообщение Request timed out. Это связано с тем, что отработал протокол ARP, который используется для получения неизвестного MAC-адреса получателя по известному IP-адресу. Второй тест прошел успешно, поскольку MAC-адрес получателя уже был в ARP-кеше компьютера.

Теперь проверим удаленное подлючение с компьютера на коммутатор через сеть с помощью Telnet. Для этого на комьютере запустим PuTTy и в строке Host Name (or IP address) вводим IP-адрес 192.168.1.2, который был назначен на VLAN 1 коммутатора. Выбираем протокол Telnet для подключения, оставляем порт 23 по умолчанию и нажимаем Open.

Ну что ж, осталось сохранить настройки коммутатора:

А если вам необходимо наоборот удалить сохраненные настройки и сбросить настройки коммутатора к заводским, то воспользуйтесь следующими командами:

Источник

Adblock
detector