Меню

Centos настройка pppoe соединения

Настройка сети в CentOS

Инструкция применима к CentOS версий 7 и 8, CentOS mini (минимальная сборка), Fedora.

Базовая настройка сети

Смотрим все установленные сетевые адаптеры в системе:

В результате получаем что-то подобное:

1: lo: mtu 65536 qdisc noqueue state UNKNOWN
link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
inet 127.0.0.1/8 scope host lo
valid_lft forever preferred_lft forever
2: ens32:
mtu 1500 qdisc pfifo_fast state UP qlen 1000
link/ether 00:50:56:81:28:3c brd ff:ff:ff:ff:ff:ff
inet 192.168.156.22/22 brd 192.168.159.255 scope global ens32
valid_lft forever preferred_lft forever
3: ens34:
mtu 1500 qdisc pfifo_fast state UP qlen 1000
link/ether 00:50:56:81:3f:22 brd ff:ff:ff:ff:ff:ff
inet 10.243.254.68/26 brd 10.243.254.127 scope global ens34
valid_lft forever preferred_lft forever

* Из примера видно, что в моем CentOS есть 3 сетевых карты — lo (локальная петля), ens32 и ens34 — сетевые Ethernet адаптеры.

Если нужно настроить сеть для адаптера ens32, открываем на редактирование следующий конфигурационный файл:

И приводим его к следующему виду:

DEVICE=ens32
BOOTPROTO=static
IPADDR=192.168.0.155
NETMASK=255.255.255.0
GATEWAY=192.168.0.1
DNS1=192.168.0.54
DNS2=192.168.0.11
ONBOOT=yes

. а также для CentOS 8 добавим:

Основные опции

Опция Описание Возможные значения
DEVICE Имя сетевого адаптера Должно совпадать с именем в системе. В данном примере ens32
BOOTPROTO способ назначения IP-адреса static: ручное назначение IP, dhcp: автоматическое получение IP
IPADDR IP-адрес адрес, соответствующий вашей сети
NETMASK Сетевая маска должна соответствовать вашей сети
GATEWAY Шлюз по умолчанию IP-адрес сетевого шлюза
DNS1 Основной DNS-сервер IP-адрес сервера имен
DNS2 Альтернативный DNS-сервер IP-адрес сервера имен
ONBOOT Способ запуска сетевого интерфейса yes: автоматически при старте сервера, no: запускать вручную командой
NM_CONTROLLED Указываем, должен ли интерфейс управляться с помощью NetworkManager yes: управляется NetworkManager, no: не может управляться NetworkManager

Чтобы настройки применились, перезапускаем сетевую службу.

systemctl restart network

б) для CentOS 8 вводим 2 команды:

systemctl restart NetworkManager

nmcli networking off; nmcli networking on

* в большей степени, это основное отличие версий 7 и 8. Чтобы команды смогли поменять настройки, для интерфейсов необходима настройка NM_CONTROLLED=yes.

Дополнительные опции (не обязательны для работы сети)

Опция Описание Возможные значения
IPV4_FAILURE_FATAL Отключение сетевого интерфейса, если IP-адрес (v4) имеет неверную конфигурацию yes: отключать, no: не отключать
IPV6_FAILURE_FATAL Отключение сетевого интерфейса, если IP-адрес (v6) имеет неверную конфигурацию yes: отключать, no: не отключать
IPV6_AUTOCONF Разрешает или запрещает автоконфигурирование IPv6 с помощью протокола Neighbor Discovery yes: разрешить автоконфигурирование, no: запретить
IPV6INIT Говорит о возможности использовать сетевой интерфейс для адресации IPv6 yes: адресация может использоваться, no: не используется
PEERROUTES Задает приоритет настройки шлюза по умолчанию, полученного от DHCP yes: маршрут от DHCP важнее, чем назначенный вручную, no: важнее маршрут, заданный вручную
IPV6_PEERROUTES Задает приоритет настройки шлюза по умолчанию, полученного от DHCP (для IPv6)
UUID Уникальный идентификатор сетевого интерфейса. Его можно сгенерировать самостоятельно командой uuidgen Строка из 32-х символов в формате 8-4-4-4-12.
Например: fca8cc84-6f21-4bac-9ccb-36f281321ba4

Настройка сети из консоли (командами)

Настройка из консоли будет работать только до перезагрузки системы. Ее удобно применять для временного конфигурирования или проведения тестов.

Назначение IP-адреса или добавление дополнительного к имеющемуся:

ip a add 192.168.0.156/24 dev ens32

* в данном примере к сетевому интерфейсу ens32 будет добавлен IP 192.168.0.156.

Изменение IP-адреса:

ip a change 192.168.0.157/24 dev ens32

* однако, по факту, команда отработает также, как add.

Удаление адреса:

ip a del 192.168.163.157/24 dev ens32

Добавление маршрута по умолчанию:

ip r add default via 192.168.0.1

Добавление статического маршрута:

ip r add 192.168.1.0/24 via 192.168.0.18

Удаление маршрутов:

ip r del default via 192.168.160.1

ip r del 192.168.1.0/24 via 192.168.0.18

Команда ifconfig

В новых версиях CentOS утилита ifconfig не установлена и при вводе одноименной команды можно увидеть ошибку «Команда не найдена». Необходимо либо воспользоваться командой ip (ip address), либо установить утилиту ifconfig.

yum install ifconfig

yum install net-tools

Настройка WiFi

Принцип настройки беспроводной сети на CentOS не сильно отличается от проводной.

Создаем конфигурационный файл со следующим содержимым:

ESSID=»dmoskwifi»
MODE=Managed
KEY_MGMT=WPA-PSK
TYPE=Wireless
BOOTPROTO=none
NAME=dmoskwifi
ONBOOT=yes
IPADDR=192.168.1.50
NETMASK=255.255.255.0
GATEWAY=192.168.1.1
DNS1=192.168.1.1
DNS2=77.88.8.8

* где dmoskwifi — название WiFi сети (SSID).

Несколько IP на одном сетевом адаптере

DEVICE=ens32:1
BOOTPROTO=static
IPADDR=192.168.0.156
NETMASK=255.255.255.0
GATEWAY=192.168.0.1
DNS1=192.168.0.54
DNS2=192.168.0.11
ONBOOT=yes

Читайте также

Другие статьи на тему сетевых настроен CentOS:

Источник

Заметки Системного Администратора

9 июн. 2012 г.

Настройка шлюза на ОС Linux (CentOS) + OSPF, cisco, zebra, два pppoe соединения

Организовать бесперебойную работу производственной базы, офисов, IP телефонии и интернета, при условии, что один из провайдеров жив, без использования скриптов.

Реализовать данную задачу протоколом динамической маршрутизации OSPF. За переключение между pppoe соединениями будет отвечать демон zebra.

В результате, посредством ospf и zebra, мы получим динамическую маршрутизацию между точками 192.168.31.1(cisco, т.к. на нее приходит поток Е1, нам она очень важна, а так же в данной конфигурации на ней висят офисы) и 192.168.31.2(Linux, главный шлюз, за которым находится сервер IP телефонии и производственная база), а так же динамический выбор маршрута из двух подключений ppooe (ppp0 и ppp1), при чем ppp0 будет оставаться всегда приоритетным.

Под катом продолжение.

eth0 ip address 192.168.1.2/24
eth0.10 ip address 192.168.31.10/30
eth0.11 ip address 192.168.40.10/30
eth0.12 ip address 192.168.31.5/30
lo:0 ip address 192.168.31.2/32
ppp0
ppp1

configure terminal
router ospf 1
router-id 192.168.31.1 redistribute static subnets
network 192.168.31.1 0.0.0.0 area 1
network 192.168.30.0 0.0.0.255 area 1
network 192.168.31.8 0.0.0.3 area 1
network 192.168.40.8 0.0.0.3 area 1

hostname centos.blablabla.local
password blablabla
enable password blablabla
!
log file /var/log/quagga/zebra.log
!
! interface description
!
interface ppp0
description Rostelecom
link-detect
!
interface ppp1
description AgencyJin
link-detect
!
ip route 0.0.0.0/0 ppp0 10
ip route 0.0.0.0/0 ppp1 200
!
interface eth0
ip address 192.168.1.2/24
!
interface eth0.10
ip address 192.168.31.10/30
!
interface eth0.11
ip address 192.168.40.10/30
!
interface eth0.12
ip address 192.168.31.5/30
!
interface lo:0
ip address 192.168.31.2/32

!
! OSPFd sample configuration file
!
!
hostname centos.primer.local
password primer
enable password superprimer
!
router ospf
ospf router-id 192.168.31.2
network 192.168.31.2/32 area 1
network 192.168.1.0/24 area 1
network 192.168.31.4/30 area 1
network 192.168.31.8/30 area 1
network 192.168.40.8/30 area 1
!
log file /var/log/quagga/ospfd.log

service zebra start
service ospfd start
chkconfig zebra on
chkconfig ospfd on

Источник

Настройка сети в CentOS 7

Для CentOS это актуальный вопрос. Тут немного изменили параметры настройки. А кто то их и вовсе не знал. Сегодня будем разбирать, как провести первоначальную настройку сети из командной строки.

В данной статье разберем, как настроить или изменить уже имеющиеся настройки локальной сети на CentOS 7.

Вообще первоначальная настройка сети производилась, когда осуществлялась установка CentOS 7, но если ставили не вы или вам надо что то изменить, то данная статья точно для вас!

Содержание:

1. Как настроить статический IP-адрес в CentOS 7

2. Как настроить адрес по DHCP в CentOS 7

3. Как настроить DNS в CentOS 7

4. Как настроить основной шлюз в CentOS 7

5. Как изменить hostname в CentOS 7

6. Как перезапустить сеть в CentOS 7

7. System config network tui в CentOS 7

# Как настроить статический IP-адрес в CentOS 7

Итак, вы хотите посмотреть настройки сети, но вы устанавливали сборку «minimal» то по привычному запросу ifconfig вы в ответ получите вот такое:

Это говорит нам о том, что у нас нет такого пакета. Для работы его работы и прочими сетевыми утилитами нужно установить пакет net-tools. Для этого выполним следующую команду:

Теперь попробуем снова ввести ifconfig:

Если вы не хотите устанавливать дополнительные пакеты или на данном этапе у вас не работает сеть/интернет, то можно воспользоваться командой ip с параметром addr:

Тут мы увидели наши параметры, название нашей сетевой карты. В моем случае — eno16777736, и IP адрес.

Теперь давайте ее отредактируем. Допустим, нам нужно сменить или установить ip адрес. Для этого переходим в директорию /etc/sysconfig/network-scripts и открываем на редактирование файл ifcfg-eno16777736. Этот файл имеет примерно следующее содержание:

Для установки статического IP адреса нам необходимо на строчке BOOTPROTO установить BOOTPROTO=none

Указать ДНС:
DNS1=8.8.8.8

Прописываем IP:
IPADDR0=172.16.0.30

Указываем нужную маску:
PREFIX0=24

Прописываем шлюз по умолчанию:
GATEWAY0=172.16.0.1

И чтобы у нас сетевая карта «поднималась» при запуске ОС, необходимо в этом файле найти параметр ONBOOT и прописать ему yes.

В итоге у нас должно получится что то типа этого:

Для немедленного применения изменений перезапустим сеть:

Проверяем, все ли мы сделали верно:

Видим что наши параметры применились. Значит все было сделано верно.

# Как настроить адрес по DHCP в CentOS 7

Предположим что у вас сетевая карта настроена на статический IP, а вы хотите получать настройки по DHCP. Тут будем действовать в обратном порядке. переходим в папку /etc/sysconfig/network-scripts и открываете файл на редактирование с названием вашей сетевой картой. Название сетевой можно посмотреть командой ifconfig или ip addr. Находим там и удаляем параметры DNS, IPADDR, PREFIX, GATEWAY а в параметре BOOTPROTO указываем значение «dhcp».

Для немедленного применения изменений перезапустим сеть:

Проверяем, все ли мы сделали верно:

# Как настроить DNS в CentOS 7

Производить настройки DNS будет все в том же файле/etc/sysconfig/network-scripts/название_вашей_сетевой_карты

В данный файл можно добавить столько DNS серверов, сколько требуется. Например:

Сохраняем файл и перезапускаем сеть.

# Как настроить основной шлюз в CentOS 7

Проверим, какой у нас шлюз по умолчанию установлен в системе:

Строка с Destination 0.0.0.0 определяет адрес шлюза. Если у вас ее нет, либо в поле Gateway установлен неверный шлюз, то можно это изменить. Устанавливаем шлюз по-умолчанию:

# Как изменить hostname в CentOS 7

Если вы не сменили при установке Hostname или вы хотите его изменить, то сделать это совсем не сложно. Для начала давайте проверим, какой hostname у нас установлен:

В моем случае это centos.home. Допустим мы хотим сделать имя: superserver.work, для этого необходимо отредактировать фай /etc/hostname

После того, как изменили имя, давайте проверим, что у нас получилось:

Как видим, имя сменилось. Значит мы все сделали верно. Как видите, это сделать не так сложно.

P.S.: Для смены hostname перезагрузка не требуется.

# Как перезапустить сеть в CentOS 7

Я уже выше несколько раз описывал как это сделать, но повторюсь еще раз. Чтобы применить новые настройки сетевой карты, не обязательно перезагружать весь сервер. Для этого можно просто перезапустить сетевые интерфейсы следующей командой:

Выполнив данную команду сетевые интерфейсы перезапускаются и считывают настройки из их конфигов.

# System config network tui в CentOS 7

Так же для управления сетевыми интерфейсами и настройками в CentOS можно воспользоваться графической утилитой nmtui. Это сделать очень просто. Достаточно запустить ее в консоли:

Допустим, мы хотим изменить IP адрес через графический интерфейс, выбираем «Изменить соединение»

Выбираем сетевое подключение, в моем случае оно одно, и нажимаем «Изменить …»

Меняем настройки, которые вы хотите изменить и нажимаем «ОК«.

Вот так просто через графический интерфейс можно настраивать сеть. Если по какой то причине у вас не установлен данный пакет, то установить его можно следующей командой:

Заключение

В данной статье я постарался подробно рассмотреть основные первоначальные настройки сети в CentOS 7. Если у вас возникли какие-либо трудности, задавайте их в комментарии, я постараюсь ответить на все ваши вопросы.

Источник

Читайте также:  Настройка терморегулятора котла лемакс
Adblock
detector